$ cscli version
version: v1.7.4-db3efdbf
Codename: alphaga
BuildDate: 2025-12-09_09:08:11
GoVersion: 1.25.5
Platform: docker
libre2: C++
User-Agent: crowdsec/v1.7.4-db3efdbf-docker
Constraint_parser: >= 1.0, <= 3.0
Constraint_scenario: >= 1.0, <= 3.0
Constraint_api: v1
Constraint_acquis: >= 1.0, < 2.0
Built-in optional components: cscli_setup, datasource_appsec, datasource_cloudwatch, datasource_docker, datasource_file, datasource_http, datasource_journalctl, datasource_k8s-audit, datasource_kafka, datasource_kinesis, datasource_loki, datasource_s3, datasource_syslog, datasource_victorialogs, datasource_wineventlog, db_mysql, db_postgres, db_sqlite
What happened?
I'm running Crowdsec on my Synology NAS. Synology is notoriously behind on keeping their docker implementation up to date. Last night, my Crowdsec container was updated failed to start properly.
It turns out it's because I have a docker datasource and the client API in Crowdsec was updated. The error in the Corwdsec logs says it clearly:
Unfortunately, I can't update my docker installation (thanks Synology!) Is there a way to let Crowdsec use an older version of the Docker client API?
What did you expect to happen?
.
How can we reproduce it (as minimally and precisely as possible)?
Install Crowdsec on a Synology NAS and configure a docker datasource
Anything else we need to know?
No response
Crowdsec version
Details
OS version
Details
Enabled collections and parsers
Details
Acquisition config
Details
```console # On Linux: $ cat /etc/crowdsec/acquis.yaml /etc/crowdsec/acquis.d/*source: docker
container_name:
labels:
type: authentik
On Windows:
C:> Get-Content C:\ProgramData\CrowdSec\config\acquis.yaml
paste output here
Config show
Details
Prometheus metrics
Details
Related custom configs versions (if applicable) : notification plugins, custom scenarios, parsers etc.
Details